Commodore PET 3032 repair log

 Local friends Commodore PET 3032. Looks physically in very good shape, no rust or previous repair attempts. Issue: no picture, only stripes across screen. By looking at the mainboard, I figured that this must be a model with Basic 2.0 installed, because of the numbers on the ROM chips.

I started by checking the PSU and voltages from the transformer. They all are within spec. Main Capacitors are in normal shape even after all this time and measures fine. I am ignoring the huge cap with the screw terminals. Its only mission is to prevent that the PET does not interfere with other devices in the room. It has no impact on the PET itself, and can even be bypassed. I will leave it alone, since it seems to work.The regulators and transistors are all working within spec.
So I moved on to voltages at the RAM chips. They show 4.96, so all OK there. 
At this point I felt like looking at the signals. I started with the 6502 CPU. Input and output is stuck high! As a matter of fact every logic chip seems to be stuck eighter high or low. I probed the oscillator, and it works. 

At this point, I wanted to look at the reset signal generated by the 555 timer.It does have a steady 4.96v, but it does not produce any reset signal. I replaced the timer, and it now produce the reset signal. But the computer still has no picture.

I went on to verify the ROM Chips. The character and screen editor ROMs are 2516 chips, and are fortunately pin compatible with the more common 2716. So I compared the content of those chips with the original files (found at zimmers.net) using my eprom programmer set to ST2716. Both chips verified OK. (Char chip with Norwegian characters)

So I went over to test the rest of the ROMs. The rest of the ROM chips are 2332 chips, and not compatible with my programmer, so I had to make an adapter. All 4 of those have checksum errors. One is blank and the rest has only partial content. This means that I have to manufacture some adapters. Looking at the datasheets of different EPROM types, I decided that the best option would be to make a 2764 to 2332 adapter. It will not require any resistors or diodes, and I have several in stock, since I use them on other projects like my testcarts for C64.

So untill the adapters are done, I have to put the PET aside to work on something else.
--------------------
13 days later:
Finally my newly designed PCBs arrive from the factory!!


Some soldering, and the new adapters are ready for the freshly burned 27C64 ROMs.


Success! The H DRIVE and V DRIVE signals are now arriving to the video connector.

But still no picture.. Lets look at the 9" CRT and find oth the partnumber.


There does not seem to be any obvious problems by looking at the videoboard. 
After some probing, it looks like Q13 has a short, so does C17, but likely the C17 only shows a short due to Q13. Also, there are several caps that also has a short. C27, C12, C16 measures a short. Also, the horizontal sync pulses that go through Q11 and Q12 have strange levels when probing with my oscilloscope. To my surprise, Q14 also has a B-E short.
Unfortunately, I dont have all these parts, so I need to make a second parts order...